Background Workers Down

Incident Report for CrystalCommerce

Resolved

We got the Resque Scheduler back online, and the backed up queues have cleared now.
Posted Dec 12, 2024 - 08:21 PST

Identified

We've found the root cause of the background workers issue this morning, and are implementing a fix. It may take a while for all of the stalled jobs to catch up, as there are a lot of them in the queue. We are working on getting them all to process them as quickly as possible without overloading the system.
Posted Dec 11, 2024 - 10:51 PST

Investigating

We are currently working on resolving an issue with Resque Scheduler, which controls all of the background jobs. That means right now all background jobs are down. This includes batch updates, mass create, order status changes, and automated emails (basically anything that runs behind the scenes).

Our top priority is getting this working again. We've tried restarting/redeploying the scheduler, but it's still timing out. We are continuing to investigate what is causing the issue, at which point we will fix it asap.
Posted Dec 11, 2024 - 10:15 PST
This incident affected: Admin and POS.