Frontend Website "under heavy load (queue full)" Errors

Incident Report for CrystalCommerce

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 11:20 PDT

Monitoring

We've implemented some new security measures and have been able to block multiple IP ranges that were responsible for overloading the system. We are seeing sites loading now. We are continuing to monitor the situation and add addresses to the black list as needed.
Posted Aug 25, 2025 - 21:11 PDT

Investigating

Our engineering team is working on resolving an issue where frontend websites aren't loading and are instead displaying an error page that says "This website is under heavy load (queue full)"
Our system is processing user activity that is far above average, and we are investigating any potential malicious or illegitimate activity. We are also as looking into ways to optimize the system to handle the increase in traffic/activity.
Getting websites loading properly is our top priority.
Posted Aug 25, 2025 - 10:38 PDT
This incident affected: Frontend.