Websites Under Heavy Load

Incident Report for CrystalCommerce

Resolved

We have been able to block the attack, and we're increasing the frequency of the IP banner trying to catch the offending IPs earlier.
Posted Sep 17, 2025 - 15:40 PDT

Investigating

We're seeing spikes in website response times again today, resulting in "website is under heavy load" errors. We are continuing to look into this. We'll being deploying some aggressive countermeasures, which will disable product landing pages but at least allow websites to load. This is a short-term solution to get the websites to load. We'll be re-enabling the product landing pages once we can block the offending IPs.
Posted Sep 17, 2025 - 11:07 PDT
This incident affected: Frontend.