"Website is under heavy load" error on frontend sites

Incident Report for CrystalCommerce

Resolved

We've deployed a fix, and websites are loading again now.
Posted Sep 16, 2025 - 12:46 PDT

Identified

We investigated, and the traffic it looks like a new DDOS.
We are deploying some countermeasures.
Posted Sep 16, 2025 - 11:57 PDT

Investigating

We're seeing another spike in website response times today, resulting in "website is under heavy load" errors. Our team is investigating, and working on blocking whatever is hitting our system. Most likely bots, scrapers, or DDOS.
Posted Sep 16, 2025 - 11:24 PDT
This incident affected: Frontend.