Frontend Website Downtime

Incident Report for CrystalCommerce

Resolved

We've resolved the issue. Currently, we have a safeguard in place that will require customer login for viewing product pages. We are still working on building other less intrusive safeguards to protect against future attacks.
Posted Sep 29, 2025 - 10:57 PDT

Update

Product landing pages (the page a customer goes to when clicking on a product) are disabled, and sites are loading again. We are still working on the other fix, so that we can re-enable product landing pages. Products can still be added to the cart via search results.
Posted Sep 24, 2025 - 11:39 PDT

Identified

Our websites are currently showing error pages and not loading. Our developers are working on resolving this issue. We attempted a frontend redeployment earlier this morning, but that didn't seem to help

Currently, we are doing two things:

1. We'll be deploying the update to disable product landing pages as a temporary stop-gap solution to decrease the load.

2 While that is in place, we are also working on a longer term fix which we anticipate will take a couple hours to deploy (rough estimate: around 1PM Pacific time). Once that is deployed, we'll look into restoring the product landing pages.
Posted Sep 24, 2025 - 10:55 PDT
This incident affected: Frontend.